Jump to content
  • 0

How to convert an ASUS T100TA with Windows 8.1/10 to Linuxmint?


Question

A friend gave me an ASUS T100TA with 2 GB Ram and 32 GB storage running Windows 8.1 (but somehow converted to an older version of Windows 10). I'd like to get rid of the Windows as it takes up 24G of 32G of disk space. I've created a bootable (I think) USB drive for Linuxmint but can't change the Bios to boot from it. (Or else the USB isn't bootable!) I can get to the Bios screen but I can't go to the boot priority choice to make the USB port the first choice over the internal HDD.

Can anyone suggest how to get around this?

Bob Thomson, Ottawa, Canada

Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
1 hour ago, Bob Thomson said:

A friend gave me an ASUS T100TA with 2 GB Ram and 32 GB storage running Windows 8.1 (but somehow converted to an older version of Windows 10). I'd like to get rid of the Windows as it takes up 24G of 32G of disk space. I've created a bootable (I think) USB drive for Linuxmint but can't change the Bios to boot from it. (Or else the USB isn't bootable!) I can get to the Bios screen but I can't go to the boot priority choice to make the USB port the first choice over the internal HDD.

Can anyone suggest how to get around this?

Bob Thomson, Ottawa, Canada

Hi Bob,
Can you post a photo of your laptop's BIOS? I need to know what settings are there to help you.

 

Thanks.

Shovon

Link to post
Share on other sites
  • 0
1 hour ago, Bob Thomson said:

A friend gave me an ASUS T100TA with 2 GB Ram and 32 GB storage running Windows 8.1 (but somehow converted to an older version of Windows 10). I'd like to get rid of the Windows as it takes up 24G of 32G of disk space. I've created a bootable (I think) USB drive for Linuxmint but can't change the Bios to boot from it. (Or else the USB isn't bootable!) I can get to the Bios screen but I can't go to the boot priority choice to make the USB port the first choice over the internal HDD.

Can anyone suggest how to get around this?

Bob Thomson, Ottawa, Canada

If you have American Megatrends Inc 2012 BIOS, then go to the Security tab and disable Secure Boot from there. Once you save the changes, go to the BIOS again and navigate to the Save & Exit tab. Your USB bootable thumb drive should appear in the Boot Override section. 
 

I hope this helps. Wishing you all the best.

Shovon

Link to post
Share on other sites
  • 0
1 hour ago, Shahriar Shovon said:

If you have American Megatrends Inc 2012 BIOS, then go to the Security tab and disable Secure Boot from there. Once you save the changes, go to the BIOS again and navigate to the Save & Exit tab. Your USB bootable thumb drive should appear in the Boot Override section. 
Shovon

It is indeed the American Megatrends Inc 2012 BIOS. However, in the Security tab or Boot screens I can't use the arrow keys to change the priority. I'm wondering if it's because there is an administrator password that I don't know.

Link to post
Share on other sites
  • 0
5 minutes ago, Bob Thomson said:

It is indeed the American Megatrends Inc 2012 BIOS. However, in the Security tab or Boot screens I can't use the arrow keys to change the priority. I'm wondering if it's because there is an administrator password that I don't know.

When I go to the alternative USB device screen it recognizes my USB (SanDisk) but then just shuts down when I ask it to boot from that device.

Link to post
Share on other sites
  • 0
1 hour ago, Bob Thomson said:

It is indeed the American Megatrends Inc 2012 BIOS. However, in the Security tab or Boot screens I can't use the arrow keys to change the priority. I'm wondering if it's because there is an administrator password that I don't know.

Maybe. Ask the previous owner about it. 

I don't think you can boot Linux on this device as long as Secure Boot is enabled.

Link to post
Share on other sites
  • 0
1 hour ago, Bob Thomson said:

When I go to the alternative USB device screen it recognizes my USB (SanDisk) but then just shuts down when I ask it to boot from that device.

What program did you use to make the bootable USB thumb drive of LinuxMint?

Maybe you have created a BIOS based bootable USB thumb drive. You need the UEFI one. You can use Rufus to make a UEFI supported bootable USB thumb drive.

 

image.png.98cb6aae651eb278439c0040ddaa6d0f.png 

Link to post
Share on other sites
  • 0
2 hours ago, Shahriar Shovon said:

What program did you use to make the bootable USB thumb drive of LinuxMint?

Maybe you have created a BIOS based bootable USB thumb drive. You need the UEFI one. You can use Rufus to make a UEFI supported bootable USB thumb drive.

 

image.png.98cb6aae651eb278439c0040ddaa6d0f.png 

I used Rufus and created both (at different times) a FAT32 and an NTFS file system  on the same 16 GB USB. For both scenarios I used MBR partitions and with a 10GB persistent partition size, with the BIOS or UEFI target system option as you suggest. Running my Lenovo with Ubuntu 18 and BIOS set to go to the USB, it defaulted to the HDD Ubuntu 18 boot, making me wonder if a truly bootable USB was created.

Link to post
Share on other sites
  • 0
6 hours ago, Bob Thomson said:

I used Rufus and created both (at different times) a FAT32 and an NTFS file system  on the same 16 GB USB. For both scenarios I used MBR partitions and with a 10GB persistent partition size, with the BIOS or UEFI target system option as you suggest. Running my Lenovo with Ubuntu 18 and BIOS set to go to the USB, it defaulted to the HDD Ubuntu 18 boot, making me wonder if a truly bootable USB was created.

Don't create bootable USB drive on NTFS file systems. FAT32 is usually the best way to go.

You have to select the USB drive to boot from manually. Usually theres a key (F8 or some other function keys dependening on your device) that you can press just after pressing the power button to bring up the boot selection menu.  
 

Try the DD Image mode to create a bootable USB drive from Rufus. Just after you click on START, you should see the following window.

image.png.b2131ad395ce0a20f24264fd899f0d81.png

 

I hope this will work.

Link to post
Share on other sites
  • 0
On 11/5/2020 at 12:20 AM, Shahriar Shovon said:

Don't create bootable USB drive on NTFS file systems. FAT32 is usually the best way to go.

You have to select the USB drive to boot from manually. Usually theres a key (F8 or some other function keys dependening on your device) that you can press just after pressing the power button to bring up the boot selection menu.  
 

Try the DD Image mode to create a bootable USB drive from Rufus. Just after you click on START, you should see the following window.

image.png.b2131ad395ce0a20f24264fd899f0d81.png

 

I hope this will work.

I tried this but the option re DD Image mode never appeared.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...