Jump to content
  • 0

Remember Passwords?


Question

Good day all.

I'm brand new to both Linux and Mint, having just installed on my HP EliteBook the latest version.  I'm coming over from Windows 7 Professional.

So far things are going well...but, I am mystified by a behavior that is akin to Windows' User Access Control (UAC), and which I presume is a security feature.

I'd like to explain this, but just know in advance that I will probably not use the appropriate terms, so forgive that in advance.

I am a long-time user of VPN services.  Part of that involves the installation and use of a VPN client on my laptop.  This client is currently installed and functioning properly, other than it's not starting when I login as I wish it to.  I have placed a check in the box for that purpose, and still it does not come up.  My best guess at this point for this situation is that LM is requiring my password, as it seems to do for quite a few actions I undertake, even though LM does not present me the opportunity to enter my password to start the VPN client.  After searches of various other forums as well as the LM installation itself, I am unable to locate a "how-to" for how to avoid being prompted for my password so much.

I do NOT want to remove the password (although I would like to change it at some point).  Rather, I would like to have LM ask me just the one time when I login and at no other times...OR, failing that, simply know where that setting is located so that I can dis/enable it as I see fit.

Is it just very simple and I've missed?

Thank you for your help.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
8 hours ago, SBvdE said:

VPN.ac, but I'm confused as to what that has to do with it.

Thanks.

Do VPN.ac provide their own software for connecting to the VPN service? Or Do you use Network Manager on LinuxMint to connect to the VPN service? Or Do you use the OpenVPN client to connect to the VPN service?

This is important as the solution depends on how you connect to the VPN service. 

Thanks.

Link to post
Share on other sites
  • 0

I see.

VPN.ac provides their own software.  I will note that VPN.ac does provide directions for using the Network Manager instead.  But from what I could tell, this was a more onerous task, as I'm sure you know.

Thanks.

Link to post
Share on other sites
  • 0
6 hours ago, SBvdE said:

I see.

VPN.ac provides their own software.  I will note that VPN.ac does provide directions for using the Network Manager instead.  But from what I could tell, this was a more onerous task, as I'm sure you know.

Thanks.

I see. You can do it using the Network Manager or the OpenVPN client. But this is not very straightforward as you have said. 

Link to post
Share on other sites
  • 0

Ok...so back to my original issue, which is (quoting): "...I would like to have LM ask me (for my password) just the one time when I login and at no other times...OR, failing that, simply know where that setting is located so that I can dis/enable it as I see fit."

Anyone?  Thanks.

Link to post
Share on other sites
  • 0
20 hours ago, SBvdE said:

Ok...so back to my original issue, which is (quoting): "...I would like to have LM ask me (for my password) just the one time when I login and at no other times...OR, failing that, simply know where that setting is located so that I can dis/enable it as I see fit."

Anyone?  Thanks.

You can add your user to the /etc/sudoers file and enable passwordless sudo access.


Open /etc/sudoers file with the following command:

$ sudo nano /etc/sudoers

 

Then, add the following line to your /etc/sudoers file.

<username> ALL=(ALL) NOPASSWD:ALL

Change <username> to the login username of your LinuxMint OS.

 

Once you're done, press <Ctrl> + X followed by Y and <Enter> to save the /etc/sudoers file.

 

I hope this helps.

Wish you all the best.

Shovon

Link to post
Share on other sites
  • 0
On 6/20/2020 at 8:11 PM, Shahriar Shovon said:

You can add your user to the /etc/sudoers file and enable passwordless sudo access.


Open /etc/sudoers file with the following command:

$ sudo nano /etc/sudoers

 

Then, add the following line to your /etc/sudoers file.

<username> ALL=(ALL) NOPASSWD:ALL

Change <username> to the login username of your LinuxMint OS.

 

Once you're done, press <Ctrl> + X followed by Y and <Enter> to save the /etc/sudoers file.

 

I hope this helps.

Wish you all the best.

Shovon

I will give this a try; thank you.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...